[Gfoss] Qgis - GPS

Lami Gis3w lami a gis3w.it
Gio 2 Lug 2009 16:05:23 CEST


Ciao Michele,

il motivo della riproiezione non corretta potrebbe essere legato al 
fatto che nel men¨ Impostazioni -> Opzioni -> CRS hai impostato come 
sistema di proiezione di default (cioŔ quello da associare in automatico 
agli strati non associati a nessun sistema di proiezione) proprio Gauss 
Boaga.

I tuoi punti scaricati da GPS non sono associati a nessun sistema di 
riferimento e quindi vengono associati al Gauss Boaga. Ecco perchŔ 
quando prova la riproiezione al volo non succede niente.
Vai allora sulla finestra di ProprietÓ del file .gpx e, nell'etichetta 
'Generale', associa il sistema di proiezione Wgs84 LatLong (EPSG code: 
4326). Infatti al di lÓ di come vedi i punti sul gps quando arrivi a 
scaricarli verranno sempre scaricati in WGS84 Lat Long.

A questo punto riprova la riproiezione al volo e guarda se tutto funziona.

PS: Potrebbe anche darsi che non hai modificato il men¨ Impostazioni -> 
Opzioni -> CRS...in quel caso, essendo WGS84 il sistema di proiezione di 
default, avresti sia CTR che i files .gpx associati al WGS84 con il 
solito risultato.
In questo caso allora devi cambiare il sistema di proiezione associata 
alla CTR, ponendolo come Gauss Boaga, e tutto dovrebbe funzionare.

PS2: come diceva Luca, attento ai Parametri towgs84 che migliorano la 
precisione nella riproiezione, Ŕ meglio usare una proiezione 
personalizzata con queste specifiche:

+proj=tmerc +lat_0=0 +lon_0=9 +k=0.999600 +x_0=1500000 +y_0=0 
+ellps=intl +units=m +towgs84=-104.1,-49.1,-9.9,0.971,-2.917,0.714,-11.68



Ciao
Leonardo


Clara Tattoni ha scritto:
> micros a bresciaonline.it wrote:
>   
>> Si, ho abilitato la riproiezione al volo, ma continua a proiettarmi i waipoint con un valore numerico in gradi anzichŔ in unitÓ metriche come impostato per il progetto, pertanto il punto risulta completamente fuori.
>> Per chiarezza, ho queste impostazioni:
>> GPS: 
>> - formato posizione = UTM UPS
>> - Map Datum = Roma 1940
>> - waipoint visualizzato sul GPS = circa a 32T UTM 0600000 - 5050000
>> QGIS:
>> - elissoide = Hayford
>> - sistema di coordinate = Proiettate ; Transverse mercator ; Monte Mario zona 1 (EPGS 3003);
>> - UnitÓ = metri
>> La cartografia Ŕ un CTR della regione lombardia con coordinate nei dintorni di 1600000 - 5050000, mentre i punti presi con il GPS nell'importazione come da istruzioni vanno a finire alle coordinate di circa 10.xxxxx - 45.xxxx
>> Che fare?
>> Grazie
>> Michele
>>
>>     
>
> prova ad abilitare la richiesta del sistema di riferimento nelle Opzioni
> di Qgis (Prompt for CRS) e specifica il sistema di riferimento dei WP
> *ogni volta* che li carichi. Se non Ŕ specificato un sistema di
> riferimento nei dati, qgis di default attribuisce wgs84.
> Ciao
>
> Clara
> _______________________________________________
> Iscriviti all'associazione GFOSS.it: http://www.gfoss.it/drupal/iscrizione
> Gfoss a faunalia.it
> http://lists.faunalia.it/cgi-bin/mailman/listinfo/gfoss
> Questa e' una lista di discussione pubblica aperta a tutti.
> I messaggi di questa lista non rispecchiano necessariamente
> le posizioni dell'Associazione GFOSS.it.
>   


-- 
Leonardo Lami
Gis3W
Tel. +39 349 1310164
E-mail: lami a gis3w.it
Web: www.gis3w.it
Via Colombo, 3 - 51010 Massa e Cozzile (PT)



Maggiori informazioni sulla lista Gfoss