<div dir="ltr">Io uso spatialite-gui 1.6.0.2 installato dai repo di ubuntu 12.10 senza particolari problemi.<div><br></div><div>Ho provato a compilare la 1.7 ma mi dice che mi manca la libreriaWxWidget. Da una ricerca veloce nei repo non l'ho trovata e li mi sono fermato. Probabilmente va scaricata da qui (<a href="http://www.wxwidgets.org/">http://www.wxwidgets.org/</a>).</div>
<div><br></div><div>Luca</div><div><br></div></div><div class="gmail_extra"><br><br><div class="gmail_quote">Il giorno 12 febbraio 2014 10:18,  <span dir="ltr"><<a href="mailto:a.furieri@lqt.it" target="_blank">a.furieri@lqt.it</a>></span> ha scritto:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">chiedo scusa a Daniele per il double-posting, ma mi sono accorto<br>
solo ora che ieri sera avevo risposto solo a lui e non alla lista ;-)<div class=""><br>
<br>
<br>
On Tue, 11 Feb 2014 22:35:25 +0100, Daniele Bonaposta wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
Ciao a tutti, ho un problema a lanciare Spatialite gui.<br>
Tramite il gestore pacchetti o il software center riesco a scaricare la<br>
versione 1.6 ma se provo a lanciarla dal menu non succede nulla.<br>
<br>
</blockquote>
<br></div>
hai provato a lanciare l'applicazione dalla shell ?<br>
magari ti riporta qualche messaggio di errore utile a capire meglio;<br>
ad ogni buon conto, non e' la prima volta che sento lamentele da<br>
parte di utenti Ubuntu.<br>
credo di capire che il pacchetto spatialite_gui supportato dalla<br>
distro ufficiale Ubuntu (almeno su qualche versione) sia affetto<br>
da problemi tecnici abbastanza seri (= non funziona proprio).<div class=""><br>
<br>
<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
Sul sito c' il file compresso versione 1.7 e se provo a lanciare<br>
da qui ottengo un errore:<br>
<br>
</blockquote>
<br></div>
su quale sito ? di quale "file compresso" stiamo parlando ?<div class=""><br>
<br>
<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
Da terminale:<br>
SQLite version 2.8.17<br>
SpatiaLite version ..: 4.1.0<br>
<br>
Qualcuno ha un idea di cosa sta succedendo?<br>
<br>
</blockquote>
<br></div>
beh, se veramente stai cercando di utilizzare una sqlite 2.8.17<br>
non stupisce affatto se non funziona.<br>
<br>
- SQLite2 e' un progetto ormai definitivamente morto e sepolto da<br>
 lunghi anni; resta comunque in distribuzione per alcuni Linux<br>
 piu' che altro per motivi di retro-compatibilita' storica.<br>
 la 2.8.17 e' un vecchio fossile del 2005, e rappresenta l'ultima<br>
 versione finale (bugfixing) di SQLite2, dopo di che il progetto e'<br>
 stato dichiarato ufficialmente chiuso.<br>
<br>
- il progetto attuale e' SQLite3, che e' profondamente diverso da<br>
 SQLite2 anche se ne rappresenta la logica evoluzione; per quanto<br>
 mi risulta i DB-files non sono compatibili tra le due versioni,<br>
 e men che meno esiste una compatibilita' a livello API/ABI per<br>
 le librerie.<br>
 non si tratta certo di un'evoluzione recente, visto che la<br>
 transizione da SQLite2 a SQLite3 e' roba di dieci anni fa (2004)<br>
<br>
- per fare funzionare correttamente spatialite_gui 1.7 e' strettamente<br>
 indispensabile il supporto di una SQLite3 ragionevolmente recente:<br>
 versione 3.8.0 o successiva.<br>
<br>
insomma, la configurazione che riporti e' assolutamente paranoica e<br>
non puo' certo funzionare.<br>
<br>
modesto consiglio personale: perche' non ti fai una build "a mano"<br>
della GUI partendo dai sorgenti ?<br>
su qualsiasi Linux non richiede piu' di cinque minuti, e non richiede<br>
neppure competenze tecniche particolarmente sofisticate.<br>
<br>
ciao Sandro<div class="HOEnZb"><div class="h5"><br>
______________________________<u></u>_________________<br>
<a href="mailto:Gfoss@lists.gfoss.it" target="_blank">Gfoss@lists.gfoss.it</a><br>
<a href="http://lists.gfoss.it/cgi-bin/mailman/listinfo/gfoss" target="_blank">http://lists.gfoss.it/cgi-bin/<u></u>mailman/listinfo/gfoss</a><br>
Questa e' una lista di discussione pubblica aperta a tutti.<br>
I messaggi di questa lista non hanno relazione diretta con le posizioni dell'Associazione GFOSS.it.<br>
666 iscritti al 22.7.2013</div></div></blockquote></div><br></div>