[Gfoss] Spatialite gui su Ubuntu 12.04

a.furieri a lqt.it a.furieri a lqt.it
Mer 12 Feb 2014 10:18:01 CET


chiedo scusa a Daniele per il double-posting, ma mi sono accorto
solo ora che ieri sera avevo risposto solo a lui e non alla lista ;-)


On Tue, 11 Feb 2014 22:35:25 +0100, Daniele Bonaposta wrote:
>  Ciao a tutti, ho un problema a lanciare Spatialite gui.
> Tramite il gestore pacchetti o il software center riesco a scaricare 
> la
> versione 1.6 ma se provo a lanciarla dal menu non succede nulla.
>

hai provato a lanciare l'applicazione dalla shell ?
magari ti riporta qualche messaggio di errore utile a capire meglio;
ad ogni buon conto, non e' la prima volta che sento lamentele da
parte di utenti Ubuntu.
credo di capire che il pacchetto spatialite_gui supportato dalla
distro ufficiale Ubuntu (almeno su qualche versione) sia affetto
da problemi tecnici abbastanza seri (= non funziona proprio).


> Sul sito c'รจ il file compresso versione 1.7 e se provo a lanciare
> da qui ottengo un errore:
>

su quale sito ? di quale "file compresso" stiamo parlando ?


> Da terminale:
> SQLite version 2.8.17
> SpatiaLite version ..: 4.1.0
>
> Qualcuno ha un idea di cosa sta succedendo?
>

beh, se veramente stai cercando di utilizzare una sqlite 2.8.17
non stupisce affatto se non funziona.

- SQLite2 e' un progetto ormai definitivamente morto e sepolto da
   lunghi anni; resta comunque in distribuzione per alcuni Linux
   piu' che altro per motivi di retro-compatibilita' storica.
   la 2.8.17 e' un vecchio fossile del 2005, e rappresenta l'ultima
   versione finale (bugfixing) di SQLite2, dopo di che il progetto e'
   stato dichiarato ufficialmente chiuso.

- il progetto attuale e' SQLite3, che e' profondamente diverso da
   SQLite2 anche se ne rappresenta la logica evoluzione; per quanto
   mi risulta i DB-files non sono compatibili tra le due versioni,
   e men che meno esiste una compatibilita' a livello API/ABI per
   le librerie.
   non si tratta certo di un'evoluzione recente, visto che la
   transizione da SQLite2 a SQLite3 e' roba di dieci anni fa (2004)

- per fare funzionare correttamente spatialite_gui 1.7 e' strettamente
   indispensabile il supporto di una SQLite3 ragionevolmente recente:
   versione 3.8.0 o successiva.

insomma, la configurazione che riporti e' assolutamente paranoica e
non puo' certo funzionare.

modesto consiglio personale: perche' non ti fai una build "a mano"
della GUI partendo dai sorgenti ?
su qualsiasi Linux non richiede piu' di cinque minuti, e non richiede
neppure competenze tecniche particolarmente sofisticate.

ciao Sandro


Maggiori informazioni sulla lista Gfoss