[Gfoss] Errore Plugin profile e profilefromline su QGis 9.1

Francesco Mascioli fmascioli a hotmail.it
Mer 21 Mar 2012 09:41:54 CET


Buongiorno,
ho installato QGis 9.1 è mi si presentano dei problemi con i plugin "Profilefromline" e "profile".
Di seguito riporto i messaggi di errore che ricevo per ciascuno dei due plugin.

PER QUANTO RIGUARDA PROFILE:

In fase di avvio di QGis:


Impossibile caricare il plugin profiletool a
causa di errore chiamando il metodo classFactory()
Traceback (most recent call last):


  File "C:/OSGeo4W/apps/qgis-dev/./python\qgis\utils.py", line
164, in startPlugin

    plugins[packageName] = package.classFactory(iface)

  File
"C:\Users\Francesco/.qgis/python/plugins\profiletool\__init__.py",
line 45, in classFactory

    from profilePlugin import profilePlugin

  File "C:/OSGeo4W/apps/qgis-dev/./python\qgis\utils.py", line
309, in _import

    mod = _builtin_import(name, globals, locals, fromlist, level)

  File
"C:\Users\Francesco/.qgis/python/plugins\profiletool\profilePlugin.py",
line 32, in 

    import doProfile

  File "C:/OSGeo4W/apps/qgis-dev/./python\qgis\utils.py", line
309, in _import

    mod = _builtin_import(name, globals, locals, fromlist, level)

  File
"C:\Users\Francesco/.qgis/python/plugins\profiletool\doProfile.py",
line 29, in 

    from PyQt4.Qwt5 import *

  File "C:/OSGeo4W/apps/qgis-dev/./python\qgis\utils.py", line
309, in _import

    mod = _builtin_import(name, globals, locals, fromlist, level)

ImportError: No module named Qwt5


Versione Python:


2.7.2 (default, Jun 12 2011, 15:08:59) [MSC v.1500 32 bit (Intel)]

Versione di QGIS:



1.9.90-Alpha Alpha, 7dc3096


Percorso Python: ['C:/OSGeo4W/apps/qgis-dev/./python',
'C:\\Users\\Francesco/.qgis/python',
'C:\\Users\\Francesco/.qgis/python/plugins',
'C:/OSGeo4W/apps/qgis-dev/./python/plugins', 'C:\\OSGeo4W\\bin\\python27.zip',
'C:\\OSGeo4W\\apps\\Python27\\DLLs', 'C:\\OSGeo4W\\apps\\Python27\\lib',
'C:\\OSGeo4W\\apps\\Python27\\lib\\plat-win',
'C:\\OSGeo4W\\apps\\Python27\\lib\\lib-tk', 'C:\\OSGeo4W\\apps\\qgis-dev\\bin',
'C:\\OSGeo4W\\apps\\Python27', 'C:\\OSGeo4W\\apps\\Python27\\lib\\site-packages',
'C:\\OSGeo4W\\apps\\Python27\\lib\\site-packages\\PIL',
'C:\\OSGeo4W\\apps\\Python27\\lib\\site-packages\\win32',
'C:\\OSGeo4W\\apps\\Python27\\lib\\site-packages\\win32\\lib',
'C:\\OSGeo4W\\apps\\Python27\\lib\\site-packages\\Pythonwin', 'C:\\OSGeo4W\\apps\\Python27\\lib\\site-packages\\wx-2.8-msw-unicode']




Nell'installatore Plugin:

Il plugin dipende da qualche componente che non è presente sul sistema. 
Per abilitarlo occorre installare i seguenti moduli Python: Qwt5



PER QUANTO RIGUARDA PROFILEFROMLINE RICEVO I SEGUENTI ERRORI:

In fase di avvio di QGis:
Impossibile caricare il plugin profilefromline
a causa di errore chiamando il metodo classFactory()

Traceback (most recent call last):

  File "C:/OSGeo4W/apps/qgis-dev/./python\qgis\utils.py", line
164, in startPlugin

    plugins[packageName] = package.classFactory(iface)

  File
"C:\Users\Francesco/.qgis/python/plugins\profilefromline\__init__.py",
line 30, in classFactory

    from ProfileFromLine import ProfileFromLine

  File "C:/OSGeo4W/apps/qgis-dev/./python\qgis\utils.py", line
309, in _import

    mod = _builtin_import(name, globals, locals, fromlist, level)

  File
"C:\Users\Francesco/.qgis/python/plugins\profilefromline\ProfileFromLine.py",
line 23, in 

    from shapely.wkb import loads

  File "C:/OSGeo4W/apps/qgis-dev/./python\qgis\utils.py", line
309, in _import

    mod = _builtin_import(name, globals, locals, fromlist, level)

ImportError: No module named shapely.wkb


Versione Python:


2.7.2 (default, Jun 12 2011, 15:08:59) [MSC v.1500 32 bit (Intel)]


Versione di QGIS:


1.9.90-Alpha Alpha, 7dc3096


Percorso Python: ['C:/OSGeo4W/apps/qgis-dev/./python',
'C:\\Users\\Francesco/.qgis/python',
'C:\\Users\\Francesco/.qgis/python/plugins',
'C:/OSGeo4W/apps/qgis-dev/./python/plugins', 'C:\\OSGeo4W\\bin\\python27.zip',
'C:\\OSGeo4W\\apps\\Python27\\DLLs', 'C:\\OSGeo4W\\apps\\Python27\\lib',
'C:\\OSGeo4W\\apps\\Python27\\lib\\plat-win',
'C:\\OSGeo4W\\apps\\Python27\\lib\\lib-tk', 'C:\\OSGeo4W\\apps\\qgis-dev\\bin',
'C:\\OSGeo4W\\apps\\Python27',
'C:\\OSGeo4W\\apps\\Python27\\lib\\site-packages', 'C:\\OSGeo4W\\apps\\Python27\\lib\\site-packages\\PIL',
'C:\\OSGeo4W\\apps\\Python27\\lib\\site-packages\\win32',
'C:\\OSGeo4W\\apps\\Python27\\lib\\site-packages\\win32\\lib',
'C:\\OSGeo4W\\apps\\Python27\\lib\\site-packages\\Pythonwin',
'C:\\OSGeo4W\\apps\\Python27\\lib\\site-packages\\wx-2.8-msw-unicode']



Nell'installatore Plugin:
Il plugin dipende da qualche componente che non è presente sul sistema. 
Per abilitarlo occorre installare i seguenti moduli Python: shapely.wkb (per profilefromline).


Come posso fare per installare i componenti mancanti? Nello stesso PC ho installato anche QGis 1.7 e i due plugin funzionano correttamente.

Grazie
Francesco



----

Dr. Geol. Francesco Mascioli
Via A.L. Antinori, 65
Francavilla al Mare (CH)
mobile: +39 340 0644924

www.mascioligeostudies.com


_______________________________________________________________________________
Informazioni ai sensi del Codice della Privacy (D.L. 196/2003).
Il vostro indirizzo e-mail ci è pervenuto da pubblici registri, elenchi,
atti o documenti conoscibili da chiunque o a seguito di una vostra e-mail
a noi indirizzata. Il vostro indirizzo sarà utilizzato esclusivamente per
inviarvi le nostre informazioni e non sarà comunicato o diffuso a terzi.
Per non ricevere nostre future comunicazioni, rispondete alla e-mail
specificando nell'Oggetto "cancellami" e il vostro indirizzo verrà
rimosso dalla nostra lista.
 		 	   		  
-------------- parte successiva --------------
Un allegato HTML ? stato rimosso...
URL: <http://lists.gfoss.it/pipermail/gfoss/attachments/20120321/cc2a9bc3/attachment-0001.html>


Maggiori informazioni sulla lista Gfoss