[Gfoss] QGis - come creare simboli SVG

Andrea Peri aperi2007 a gmail.com
Gio 18 Mar 2010 08:58:50 CET


>Ho fatto una prova veloce creando 2 simbolini di 50x50 px. Li ho salvati uno
>come formato svg di inkscape e uno svg puro (come sono definiti nella finestra
>di salvataggio del programma).
>Ho copiato i 2 in /usr/share/qgis/svg/ riavviato qgis ed i simboli appaiono
>fra gli SVGmarker dell'editor di legenda, cliccando sul tasto proprietÓ dopo
>aver selezionato un simbolo (qgis 1.4 nell'editor nuovo).
>La prova l'ho fatta con punti, per le linee e superfici non o provato.

Credo di aver scoperto l'arcano.

Ancora non ho certezze, ma solo ipotesi di lavoro.

Pero' sembrano esserci due ordini di problemi.

Il primo e' che non disegnavo il font alla giusta scala e nella giusta
posizione.

Per cui usciva dalla area visualizzata e sembrava non esserci niente.

Poi pero' vi e' un altro problema, perche' sembrerebbe (uso il
condizionale, perche' con l' SVG mi muovo a tentoni)
che qgis non riconosca tutti i costrutti che inkscape sta usando.
ad esempio ho l'impressione che una forma composta di piu' oggetti ,
come ad esempio un triangolo appoggiato
su una base lineare e filled con il secchiello, non lo visualizza correttamente.

Io infatti tentavo di costruire una forma svg complessa e usarla come
markerSVG.
E forse in questa forma qgis accetta solo costrutti semplici (un oggetto
solo).

Comunque a parte eventuali vincoli all' svg, e' assodato che qgis legge il
formato inkscape,
il resto lo scopriro' con un po' di pazienza.

Grazie per l'aiuto.


-- 
-----------------
Andrea Peri
. . . . . . . . .
qwerty ÓŔý˛¨
-----------------
-------------- parte successiva --------------
Un allegato HTML Ŕ stato rimosso...
URL: <http://lists.faunalia.it/pipermail/gfoss/attachments/20100318/78a6f564/attachment.htm>


Maggiori informazioni sulla lista Gfoss