[Gfoss] R: R: Re: Problemi dopo impostazione queryeditor

mosky1980 a libero.it mosky1980 a libero.it
Mar 9 Feb 2010 11:10:33 CET


ho capito qual'Ŕ il problema ma non ho capito come risolverlo

Ho creato un webgis di prova ed ho aggiunto i plug-in (queryeditor e 
coordinate), tutto funzionave ma mi sono ricordato che nell'altro webgis 
(quello che mi dava problemi) avevo cambiato la proiezione 

DA: 

PROJECTION
  # ETRS-LAEA
  #"init=epsg:3035"
  "+proj=laea +lat_0=52 +lon_0=10 +x_0=4321000 +y_0=3210000 +ellps=GRS80 
+units=m +no_defs  no_defs"
END

A:

PROJECTION
  # WGS84
  #"init=epsg:4326"
  "+proj=longlat +ellps=WGS84 +datum=WGS84 +no_defs"
END 

Infatti dopo aver modificato la proiezione anche nel webgis di prova ho 
riscontrato lo stesso problema dell'altro. Infatti appena ho fatto questa 
modifica, quando vado a selezionare le varie feature o utilizzo il query editor 
l'extend dell'applicazione mi da questi valori [minx -18000] [miny -9000] [maxx 
18000] [maxy 9000] 

la soluzione potrebbe essere quella di lavorare con la proiezione che il file .
map utilizza dall'inizio

oppure se qualcuno di voi ha giÓ avuto di questi problemi risolvendoli mi 
sarebbe di grande aiuto.

raffaele

>----Messaggio originale----
>Da: mosky1980 a libero.it
>Data: 08/02/2010 10.11
>A: "Gfoss faunalia"<gfoss a faunalia.com>
>Ogg: [Gfoss] R: Re:  Problemi dopo impostazione queryeditor
>
>ho provato a fare delle prove notando che questo errore lo da soltanto 
>interrogando i file puntuali quelli poligonali funzionano
>
>ho provato anche a disabilitare il query builder ed ho spostato il webgis su 
>una macchina con sistema operativo win xp pro
>
>vi prego ... illuminatemi
>
>raffaele
>
>>----Messaggio originale----
>>Da: lucadeluge a gmail.com
>>Data: 04/02/2010 11.28
>>A: "mosky1980 a libero.it"<mosky1980 a libero.it>
>>Cc: <gfoss a faunalia.it>
>>Ogg: Re: [Gfoss] Problemi dopo impostazione queryeditor
>>
>>Il 04 febbraio 2010 11.09, mosky1980 a libero.it <mosky1980 a libero.it> ha 
>scritto:
>>> nel mio web gis ho configurato il plugin "queryeditor", funziona bene, ma
>>> subito mi sono accorto che dopo aver fatto una query, mi fa uno zoom su un
>>> punto che non centra niente nella query realizzata. Anche quando utilizzo 
>il
>>> comando seleziona, mi fa la stessa cosa.
>>>
>>> Cosa ho combinato ???
>>>
>>
>>che webgis e sistema operativo usi?
>>
>>> raffaele
>>
>>ciao
>>Luca
>>
>>
>>
>>
>> windows 7 e mapserver con il framework pmapper
>
>_______________________________________________
>Iscriviti all'associazione GFOSS.it: http://www.gfoss.it/drupal/iscrizione
>Gfoss a faunalia.it
>http://lists.faunalia.it/cgi-bin/mailman/listinfo/gfoss
>Questa e' una lista di discussione pubblica aperta a tutti.
>I messaggi di questa lista non rispecchiano necessariamente
>le posizioni dell'Associazione GFOSS.it.
>




Maggiori informazioni sulla lista Gfoss