[Gfoss] help errore avvio server

Andrea Peri 2007 aperi2007 a gmail.com
Lun 30 Ago 2010 00:32:28 CEST


>ho dinuovo  cancellato tutto e reinstallato tutto da zero con la speranza

Quando dici "cancellato" intendi disinstallato ? o semplicemente 
cancellato i files ?

Comunque,

Durante l'installazione ,
il setup ti chiede di indicargli l'utente con cui registrera' il 
servizio postgres e ne curera' l'avvio.
che utente gli hai indicato ? Se non gli hai indicato ne' l'utente , ne' 
la sua password lui tende a crearne uno, ma se questa e' la seconda
installazione probabilmente ne esisteva gia' uno, e se la sua password 
era diversa, la seconda volta non te lo crea, e pero' sbaglia la 
password e di conseguenza non si riesce ad avviare il servizio.

nel tuo caso l'untete dovrebbe essere "postgres".
 >- postgresql-8.4 con percorso:C:/program files

>(x86)/postgresql/8.4/bin/pg_ctl.exe runservice -n "postgresql-8.4" -d
>"C:/program files (x86)/postgresql/8.4/data" -w (con nome di avvio=
>.\postgres)


Il "nome di avvio" (./postgres) e' il nome dell'account windows.
Devi sincerarti che abbia i diritti per poter avviare il servizio 
postgres, al limite dagli i diritti di amministrazione della tua 
macchina windows.

per cui verifica che diritti di sistema ha tale account.
Poi, un'altra possibile fonte di problemi potrebbe essere la password.
Puo' darsi, infatti, che la pwd di sistema di tale account sia 
differente da quella che e' registrata nella proprieta' di avvio del 
servizio.

Se non sei piu' che sicura della password che viene impiegata,
entra come amministratore, forza il cambio della password di tale utente 
"postgres" e poi inserisci la nuova password anche nel servizio
(tasto destro, proprieta' e linguetta "account")

dopodiche ' prova ad avviare a mano il servizio con il pulsante di avvio.

se non ti si avvia, dai una occhiata negli eventi di windows che 
messaggio di errore ha generato.


claudia.santese a cooperativaimpronte.it ha scritto:
> On Sun, 29 Aug 2010 18:53:06 +0200, Andrea Peri 2007 <aperi2007 a gmail.com>
> wrote:
>
>   
>> Per prima cosa verifica se nella lista dei servizi di windows e' 
>> presente un servizio che si chiama:
>>
>> "postgresql 8.4" o qualcosa di simile.
>>
>>     
>
> Salve Andrea, 
> ho dinuovo  cancellato tutto e reinstallato tutto da zero con la speranza
> di risolvere, ma niente.
> Nei servizi di windows ne esistono due:
> -PostgreSQL con percorso C:\program files
> (x86)\postgresql\8.4\bin/pg_ctl.exe runservice -n "postgresql" -d
> "C:/program files (x86)/postgresql/8.4/data" (nome di avvio= local system)
>
> - postgresql-8.4 con percorso:C:/program files
> (x86)/postgresql/8.4/bin/pg_ctl.exe runservice -n "postgresql-8.4" -d
> "C:/program files (x86)/postgresql/8.4/data" -w (con nome di avvio=
> .\postgres)
>
> entrambi sono arrestati.
>
> premessa:lavoro sempre da prompt, aperto facendo "esegui amministratore"
>
> Ho provato a vedere lo status del server con "pg_ctl status" nella
> directori %/bin ed il risultato Ú stato:
> 1- non Ŕ configurata PGDATA--> risolvo mettendo l'opzione "-D C:\program
> files (x86)\postgresql\8.4\data" e la risposta di pg_ctl status diviene "il
> server si sta avviando" (ma non si avvia in realtÓ)
> 2- provo con pg_ctl start e mi da accesso negato sulla creazione di
> postmaster.ops--> risolvo dando il permesso all'utente Claudia di
> modificare il file postmaster.ops 
> 3 - riprovo con pg_ctl start e stavolta mi da accesso negato di scrittura
> sul file "global/config_exec_params.new"
>
> Mi sono fermata per non peggiorare la situazione :(
> Consigli?
> Grazie in anticipo..
> Claudia
>
>   



Maggiori informazioni sulla lista Gfoss