[Gfoss] style layer

Peppe83 giuseppecampagna a hotmail.com
Lun 24 Nov 2008 10:27:14 CET


rieccomi,
forse non mi sono spiegato bene o non ho capito i vostri suggerimenti, ma
sono all'inizio sia con mapserver che con geotools.


Andrea Peri wrote:
> 
> nella seconda chiamata che effettui :
> 
>>ma la mappa ritornata  praticamente quella iniziale, senza aver lo stile
applicato ....
>>questo  url per la chiamata wms:
>>http://localhost:81/cgi-bin/mapserv.exe?SERVICE=WMS&LAYERS=comuni&FORMAT=image/png&TRANSPARENT=TRUE&HEIGHT=540&BGCOLOR=0xFFFFFF&MAP=/ms4w/Apache/htdocs
>>/wms/test.map&REQUEST=GetMap&WIDTH=600&BBOX=1463370.0,4959815.0,1683168.0,5155066.0&STYLES=&SRS=EPSG:3003&VERSION=1.1.1
> 
> usi STYLE=
> ma lo passi vuoto.
> Secondo me nella url dovresti proprio togliere il parametro "STYLE="
> perche' ce lo metterebbe geotools.
> 

questa  la url che mi ritorna geotools quando gli chiedo la mappa, non la
scrivo io... e quindi il parametro STYLE  uno solo (quello vuoto) al
momento della richiesta della mappa.
ho provato a settare io lo style (con il codice che ho postato nel primo
messaggio) leggendelo dall'xml, ma nella url ritorna sempre quello di
default.

come posso fare a "modificare/settare" lo sld attraverso geotools? o mi devo
creare direttamente io la url dal mio codice?
Volevo chiedervi anche un'altra cosa che non mi  chiara (scusate la mia
confusione): che differenza c' tra STYLE e SLD. In pratica fanno entrambi
il rendering dei layer o no? per effettuare la tematizzazione, quale dei due
mi conviene usare? grazie a tutti voi per le risposte precedenti e buon
inizio di settimana.
ciao
peppe
-- 
View this message in context: http://www.nabble.com/style-layer-tp20625295p20657402.html
Sent from the Gfoss mailing list archive at Nabble.com.



Maggiori informazioni sulla lista Gfoss